errors while building Banshee

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

errors while building Banshee

Ely_en
This post has NOT been accepted by the mailing list yet.
Hello!

I would like to contribute to Banshee, but when I am trying to build it on Windows with MonoDevelop I get this error: 'The name GLib does not exist in the current context'. The problem is that I don't know how to modify the code, to make it work.

Also, I've tried to build it on Ubuntu too, but when I run the following command
sudo apt-get install git-core autoconf automake libtool intltool gcc make libgconf2.0-cil-dev libgconf2-dev

I get this:


Reading package lists... Done
Building dependency tree      
Reading state information... Done
autoconf is already the newest version.
automake is already the newest version.
gcc is already the newest version.
intltool is already the newest version.
libgconf2.0-cil-dev is already the newest version.
libtool is already the newest version.
make is already the newest version.
The following extra packages will be installed:
  libgconf2-doc
The following NEW packages will be installed:
  git-core libgconf2-dev libgconf2-doc
0 upgraded, 3 newly installed, 0 to remove and 4 not upgraded.
Need to get 1,392 B/165 kB of archives.
After this operation, 2,162 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  git-core libgconf2-dev libgconf2-doc
Install these packages without verification [y/N]? y
Err http://ro.archive.ubuntu.com/ubuntu/ raring/main git-core all 1:1.8.1.2-1
  404  Not Found
Failed to fetch http://ro.archive.ubuntu.com/ubuntu/pool/main/g/git/git-core_1.8.1.2-1_all.deb  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


What should I do?

Thank you so much!