Unable to mount MTP device when Banshee is running

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to mount MTP device when Banshee is running

dpitch40
I am trying to sync music to my 16GB Walkman using Banshee with MTP support enabled, but find that I'm unable to mount it as a MTP device when Banshee is running. When I try to do so, I'll get an error popup saying, "Could not display mtp://[usb:002,008]/. Error: the connection is closed. Please select another viewer and try again." Or "Unable to mount WALKMAN: Unable to open MTP device '[usb:002,008]'" (the MTP number can vary). If I mount the device first and then start Banshee, it will unmount. Also, after either of these happens Banshee doesn't seem to close normally and hang as when I try to quit. I am running Linux Mint 17 and Banshee 2.6.2. I was able to briefly sync an album onto my device last night, not sure why it's not working now.
Reply | Threaded
Open this post in threaded view
|

Re: Unable to mount MTP device when Banshee is running

dpitch40
Attached the output from running Banshee on the console and attempting to connect my MTP device. (The output after the device is connected starts on line 14) The exceptions I get don't appear to match either of the MTP-related bugs fixed by version 1.9.1, but I could be mistaken. I also get lots of lines outputted to standard error saying:

Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)
Device have files in "root folder" 0xffffffffU - this is a firmware bug (but continuing)

BansheeLog.txt
Reply | Threaded
Open this post in threaded view
|

Re: Unable to mount MTP device when Banshee is running

berniz95
In reply to this post by dpitch40
dpitch40 wrote
I am trying to sync music to my 16GB Walkman using Banshee with MTP support enabled, but find that I'm unable to mount it as a MTP device when Banshee is running.
Hi dpitch40,

Probably won't do but, have you tried to disable all supports but MTP ? A similar workaround did the trick with my iPod.
Reply | Threaded
Open this post in threaded view
|

Re: Unable to mount MTP device when Banshee is running

Nicholas Little

Dpitch40: please try the development version (2.9.x), as MTP support was improved somewhat this summer.

On 22 Oct 2014 07:25, "berniz95" <[hidden email]> wrote:
dpitch40 wrote
> I am trying to sync music to my 16GB Walkman using Banshee with MTP
> support enabled, but find that I'm unable to mount it as a MTP device when
> Banshee is running.

Hi dpitch40,

Probably won't do but, have you tried to disable all supports but MTP ? A
similar workaround did the trick with my iPod.



--
View this message in context: http://banshee-media-player.2283330.n4.nabble.com/Unable-to-mount-MTP-device-when-Banshee-is-running-tp4652088p4652090.html
Sent from the Banshee Media Player mailing list archive at Nabble.com.
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)

_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)
Reply | Threaded
Open this post in threaded view
|

Re: Unable to mount MTP device when Banshee is running

dpitch40
I only have MTP support enabled. I did download the 2.9.x version, but could not figure out how to install it. I tried the instructions given for installing the latest source code version (run autogen.sh) but was missing a glib dependency. Am I expected to manually install all the dependencies as well?
Reply | Threaded
Open this post in threaded view
|

Re: Unable to mount MTP device when Banshee is running

Nicholas Little

Yes, you'll need all required dependencies.

Compiling from source might sound like a lot of work but for MTP I can't recommend anything else, the updates we did make it feel faster when connecting in addition to having banshee play nice (as much as possible) with nautilus.

Unless some stuff is ported back to 2.6 you won't get those improvements. I wouldn't hold your breath for that.


_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)
Reply | Threaded
Open this post in threaded view
|

Re: Unable to mount MTP device when Banshee is running

dpitch40
I have made some progress installing version 2.9.1, but am stuck attempting to install gst-plugins-bad. How can I get support for doing this? Or are there plans to finally release 2.9.1 anytime soon?

On Wed, Oct 22, 2014 at 7:15 AM, Nicholas Little [via Banshee Media Player] <[hidden email]> wrote:

Yes, you'll need all required dependencies.

Compiling from source might sound like a lot of work but for MTP I can't recommend anything else, the updates we did make it feel faster when connecting in addition to having banshee play nice (as much as possible) with nautilus.

Unless some stuff is ported back to 2.6 you won't get those improvements. I wouldn't hold your breath for that.


_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)


If you reply to this email, your message will be added to the discussion below:
http://banshee-media-player.2283330.n4.nabble.com/Unable-to-mount-MTP-device-when-Banshee-is-running-tp4652088p4652093.html
To unsubscribe from Unable to mount MTP device when Banshee is running, click here.
NAML