Music not showing up on ipod classic

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Music not showing up on ipod classic

LadyLinux
OS: Linux Mint Quiana
Banshee version: 2.6.2
ipod: 160GB iPod classic 6th (?) generation

I bought a new iPod classic as soon as I heard they were being discontinued. I used to have an older Ipod classic and managed it through itunes on Windows, but I no longer have Windows on my computer.

I used Banshee's built in iTunes database converter and it worked well. Banshee imported the music library and everything looked fine. It even remembered my play counts!

So I plugged in the ipod and told it to sync my entire library, which is about 50 gigs of music.

It took about an hour, and copied all the files onto the iPod, and looked like everything worked, but the iPod still is saying that there are no music files on it. Banshee shows that the disk space on the ipod is used up, but only the ipod thinks it's still empty.

I tried searching and could not find any way to fix this. Does anyone have any ideas?
Reply | Threaded
Open this post in threaded view
|

Re: Music not showing up on ipod classic

berniz95
LadyLinux wrote
Banshee shows that the disk space on the ipod is used up, but only the ipod thinks it's still empty.
Dear LadyLinux, have you tried this :

In menu Edition > Preferences, thumbnail Extensions, section "devices management" :

tick off all types of devices except Apple devices.

I do not guarantee the exact wording, since I'm using a french localization.

That worked fine for me, on a similar problem on an iPod touch 2. Apparently Apple products are very exclusive.

Give us news ;)
Reply | Threaded
Open this post in threaded view
|

Re: Music not showing up on ipod classic

LadyLinux
berniz95 wrote
In menu Edition > Preferences, thumbnail Extensions, section "devices management" :

tick off all types of devices except Apple devices.
I tried this and it did not change anything.

The following threads also describe the same symptoms that I have -- that the iPod's disk space is showing that it's used up, but the ipod is convinced that it is still empty. One of the threads is from 2009 and one is from 2010, and neither has a solution posted, so I'm guessing this is still unsolved.

This is disappointing, since other than this major issue, I really like Banshee since I started working with it. I'll see if I can find some old official bug reports and if there's a solution posted there before giving up.

http://banshee-media-player.2283330.n4.nabble.com/iPod-Nano-5G-Support-tp2983675.html
http://banshee-media-player.2283330.n4.nabble.com/iPod-Sync-Issues-tp2983159.html
Reply | Threaded
Open this post in threaded view
|

Re: Music not showing up on ipod classic

LadyLinux
Over the past few days I borrowed a Windows computer, put iTunes on it and used that to reformat and renstall the software on the ipod classic. Each time I reimport my music library with Banshee, everything works perfectly from my PC -- it shows the playlists, play counts, day that it was last played and so on. But when the iPod is not connected to the PC, it says that the device is empty. So I have to guess that Banshee is not writing the database correctly so that the iPod software can read it, but Banshee can still read it just fine.

I tried using a few other programs that claim to fix errors in iPod databases, but those did not work.

I've tried out all the different full-featured music players that I could find, but the only one that comes close to iTunes as far as features is Banshee, so I will probably wind up running iTunes in a virtual Windows machine and hope this bug is fixed someday. At this point I give up, but I would be happy to provide logs or other assistance if the Banshee developers want them.

Thank you.

-LL
Reply | Threaded
Open this post in threaded view
|

Re: Music not showing up on ipod classic

berniz95
This post was updated on .
LadyLinux wrote
Each time I reimport my music library with Banshee, everything works perfectly from my PC -- it shows the playlists, play counts, day that it was last played and so on. But when the iPod is not connected to the PC, it says that the device is empty.
Dear LadyLinux,
I'm not a developer, but I guess those who are will be glad to analyze debug session outputs. I think the website tells how to submit that.

I myself would try and be more incremental. Have you tried to manually import just *one* tune, synchronize, unplug and see what happens ? (after reformatting, I mean).
That said because right after solving my own problem of iPod visibility, I optimistically loaded my entire tunes library and... the amount of tunes being synchronized at the same time resulted in a mess. So I restarted from scratch, synchronizing small batches and checking each time if they showed.

Keep in (iPod) touch !
Reply | Threaded
Open this post in threaded view
|

Re: Music not showing up on ipod classic

Nicholas Little

LadyLinux, the best troubleshooting step you can perform at this point is to try transferring tracks with another libgpod based program. If another program works but Banshee doesn't then please file a bug.

Unfortunately Apple devices are difficult to support since the synchronisation software must also update the ipod database with a value calculated for the track however I believed this only to apply to newer models-the symptoms are the same though, it appears tracks are added (and they are!) but the ipod won't acknowledge their existence.

The best solution, by far, is to sell your Apple electronic handcuffs (to someone you've recently fell out with) and purchase a device that Respects Your Freedom.

On 24 Oct 2014 07:52, "berniz95" <[hidden email]> wrote:
LadyLinux wrote
> Each time I reimport my music library with Banshee, everything works
> perfectly from my PC -- it shows the playlists, play counts, day that it
> was last played and so on. But when the iPod is not connected to the PC,
> it says that the device is empty.

Dear LadyLinux,
I'm not a developer, but I guess those who are will be glad to analyze debug
session outputs. I think the website tells how to submit that.

I myself would try and be more incremental. Have you tried to manually
import just *one* tune, synchronize, unplug and see what happens ? (after
reformatting, I mean).
That said because right after solving my own problem of iPod visibility, I
optimistically loaded my entire tunes library and... the amount of tunes
being synchronized at the same time resulted in a mess. So I restarted from
scratch, synchronizing small batches and checking each time if they showed.

Keep on (iPod) touch !



--
View this message in context: http://banshee-media-player.2283330.n4.nabble.com/Music-not-showing-up-on-ipod-classic-tp4652062p4652099.html
Sent from the Banshee Media Player mailing list archive at Nabble.com.
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)

_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)