Installing 2.9.1: Syntax error: "(" unexpected in autogen.sh

classic Classic list List threaded Threaded
44 messages Options
123
Reply | Threaded
Open this post in threaded view
|

Re: Installing 2.9.1: Syntax error: "(" unexpected in autogen.sh

7even

I still use Banshee as my main media player.

Because of the stale development I made multiple attempts over the last years, to try out numerous other players. But I didn't found one that is as good as Banshee...

My main requirements:

  • Cover View (with the option to directly play from it)
  • Intelligent Playlists
  • Quick fulltext filter feature over all fields
  • Play Queue
  • Saving Ratings and Play Count to files (as Sharky wrote as well)
  • Automatic monitoring of music folder

Especially, I don't like players where I have to do "prework" (manually building a playlist), before being able to just play some music. Also, I really don't like players where everything is just text - as well as players where everything is just cover images; one really needs both! :D :D

I am still on a Ubuntu 16.04 based system, because of my fear to not being able to compile banshee on a newer system again... but I will switch to 20.04 as soon as it is release and little bit used in the wild.

So yes, I am very open for comments, proposals and so on. Because maybe I am in real trouble in a few weeks from now.... :D :D

Am 20.04.20 um 14:58 schrieb Hendrik Maryns via banshee-list:
From the Gnome Bugzilla I got the message Banshee is no longer
developed.  So why try to install it?

Cheers, H.

Op 17-04-2020 om 07:04 schreef Sharky via banshee-list:
Nick, Christian, hey fellas,

Seems like a good time to take another crack at installing banshee 2.9.1.
Anything new I should know, or is:
https://github.com/arfbtwn/banshee/tree/feature/build
this, the latest & greatest?
Any suggestions appreciated.

Oh and hey Nick, just saw you are (/were) in Newcastle, happy days mate,
used to live there myself, cracking town.



--
Sent from: http://banshee-media-player.2283330.n4.nabble.com/
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)


      
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)

_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Installing 2.9.1: Syntax error: "(" unexpected in autogen.sh

Banshee Media Player mailing list
Hi all. Finally got around to trying again to install 2.9.1. I've logged my
steps and will post a tutorial if I get it working.

Current issue - help required if anyone has ideas - is:

./configure
# configure: error: conditional "GCONF_SCHEMAS_INSTALL" was never defined.
Usually this means the macro was only invoked conditionally.
sudo apt install libgconf2-dev # didn't work
sudo apt install libgconf-2-4 # already newest version
sudo apt install libgpod-cil-dev # didn't work
sudo apt install libgconf2.0-cil-dev # doesn't exist
./configure --disable-appledevice --disable-schemas-install
--enable-gst-native # no change

Many thanks in advance if anyone knows how to fix this.



--
Sent from: http://banshee-media-player.2283330.n4.nabble.com/
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)
Reply | Threaded
Open this post in threaded view
|

Re: Installing 2.9.1: Syntax error: "(" unexpected in autogen.sh

7even
Hi Sharky,

two months ago I tried it as well and had the same problems.

Here are my notes of how I solved them:

sudo apt install autopoint libtool libgtk2.0-dev gtk-sharp3 libgtk-3-dev
libgstreamer-plugins-base1.0-dev libdbus-glib2.0-cil libdbus-glib2.0-cil-dev
libmono-addins-gui-cil-dev libtaglib-cil-dev libsqlite3-dev

added to configure.ac:76 (don't put it on top as it does not have an effect
there):

dnl added these, for avoiding errors that break ./configure
AM_CONDITIONAL(GCONF_SCHEMAS_INSTALL, false)
AM_CONDITIONAL(ENABLE_MTP, false)
AM_CONDITIONAL(LIBMTP_SIZEOF_TIME_T_64, false)


> git submodule update --init
> autoreconf -fvis
> ./configure
> make
> make install
>
> As long as you don't change branch or update the configure.ac/m4 files
> then the first two steps can be skipped afterwards.

But it still doesn't work for me. Dunno what error was next.

I switched over to Monodevelop, trying to compile it there. There were a lot
of dependency issues, mainly around gtk#. I solved them with compiling my
own versions of these gtk# libs.

The result was Banshee compiling ok, but crashing at start in a native gtk
ui init method (or constructor).
(there were some other gtk related issues and I was able to maybe solve them
- but maybe these non-professional fixes are the cause for the crash now, I
dunno...)

No further progress since then, I'm afraid :(



-----
http://www.nskcomputing.de | http://www.site7even.de | http://x4fun.site7even.de
--
Sent from: http://banshee-media-player.2283330.n4.nabble.com/
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)
Reply | Threaded
Open this post in threaded view
|

Re: Installing 2.9.1: Syntax error: "(" unexpected in autogen.sh

Banshee Media Player mailing list
Cheers for letting me know 7. I tried the AM_conditionals and no change
either. Shame, that looked promising.

This
<https://mail.gnome.org/archives/tracker-list/2006-October/msg00129.html>  
suggests GCONF_SCHEMAS_INSTALL is referenced in aclocal.m4, which it is. And
that if it [presumably reference to GCONF_SCHEMAS_INSTALL] is removed from
"cvs" & the user does a clean checkout in git, that should solve it.
I've asked Jamie if he has any more info about what was involved - fingers
crossed.
Cheers,
Simon



--
Sent from: http://banshee-media-player.2283330.n4.nabble.com/
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)
123