Getting banshee to compile

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Getting banshee to compile

Rasmase
Hello! I'm new to GNU/Linux, just installed it a couple of days ago, but have some experience in C#, and therefore I felt like helping a project with some minor bugfixes. However, I have trouble getting Banshee to compile. When I run "autogen.sh", it gives me the following error message:

configure: error: Package requirements (gstreamer-sharp-1.0 >= 0.99.0) were not met:

No package 'gstreamer-sharp-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GST_SHARP_CFLAGS
and GST_SHARP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Error: Could not run ./configure, which is required to configure banshee

I have, of course, searched the internet to the best of my abilities for a solution to this problem. I have used the "sudo aptitude build-dep banshee" command to get the dependencies, and I have attempted installing all of the packages that look related, but to no avail. Anybody know what to do?

    - Regards, Rasmase.

_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)
Reply | Threaded
Open this post in threaded view
|

Re: Getting banshee to compile

Wade Menard
build-dep banshee is installed the dependencies for the version of banshee in the repos: 2.6.x. Version 2.9.x, which you are trying to build, requires a newer version of gstreamer-sharp. You can download the source tarball for 0.99.0 here: http://gstreamer.freedesktop.org/src/gstreamer-sharp/.
 
Gstreamer-sharp-1.0 can coexist with the system gstreamer-sharp-0.10.
 
-Wade
 
 
On Thu, Oct 16, 2014, at 07:28 PM, Rasmase wrote:
Hello! I'm new to GNU/Linux, just installed it a couple of days ago, but have some experience in C#, and therefore I felt like helping a project with some minor bugfixes. However, I have trouble getting Banshee to compile. When I run "autogen.sh", it gives me the following error message:
 
 
configure: error: Package requirements (gstreamer-sharp-1.0 >= 0.99.0) were not met:

No package 'gstreamer-sharp-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GST_SHARP_CFLAGS
and GST_SHARP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Error: Could not run ./configure, which is required to configure banshee
 
I have, of course, searched the internet to the best of my abilities for a solution to this problem. I have used the "sudo aptitude build-dep banshee" command to get the dependencies, and I have attempted installing all of the packages that look related, but to no avail. Anybody know what to do?
 
    - Regards, Rasmase.
_______________________________________________
banshee-list mailing list
 

_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)