Crashes on start after mono update

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Crashes on start after mono update

ThorFrostkorp
Hi,
I recently updated mono to version 4.8 and since, banshee 2.6.2 crashes on start. The message error is the following :

Unhandled Exception:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.MethodAccessException: Method `IBusProxy:.ctor ()' is inaccessible from method `NDesk.DBus.BusObject:.ctor ()'

I searched on Internet if people had the same issue, but as it a recent update, I couldn't find any solutions : maybe someone will know what to do ?

Attached is the output of banshee --debug.

Thanks in advance, I really like banshee and I'm using it every day !

log.txt
Reply | Threaded
Open this post in threaded view
|

Re: Crashes on start after mono update

Timotheus Pokorra
Hello,

> I recently updated mono to version 4.8 and since, banshee 2.6.2 crashes
> on
> start. The message error is the following :
>
> *Unhandled Exception:
> System.Reflection.TargetInvocationException: Exception has been thrown
> by
> the target of an invocation. ---> System.MethodAccessException: Method
> `IBusProxy:.ctor ()' is inaccessible from method
> `NDesk.DBus.BusObject:.ctor
> ()'
> *

I wonder if it is solved by an update of dbus-sharp.
For Fedora, I have seen an upgrade to dbus-sharp-0.8.1 in Rawhide.
I have not tried it though.

Timotheus

----------------------------------------------------------------
Diese Nachricht wurde versandt mit Webmail von www.tbits.net.
This message was sent using webmail of www.tbits.net.
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)
Reply | Threaded
Open this post in threaded view
|

Re: Crashes on start after mono update

ThorFrostkorp
Hello,

thanks for your answer.
Unfortunately, I already have version 0.8.1 of dbus-sharp. I tried to reinstall it but it didn't solve the problem.

Some people are facing the same problem here but there is no solution yet.

Thor.
Reply | Threaded
Open this post in threaded view
|

Re: Crashes on start after mono update

ThorFrostkorp
Ok, so mono was indeed the origin of the problem.
I downgraded it to mono-4.6.1.3-1 and it works without any issue now.

Thanks for your help, and I hope this will be corrected in the next version of mono.
Reply | Threaded
Open this post in threaded view
|

Re: Crashes on start after mono update

Timotheus Pokorra
> Ok, so mono was indeed the origin of the problem.
> I downgraded it to mono-4.6.1.3-1 and it works without any issue now.
>
> Thanks for your help, and I hope this will be corrected in the next
> version
> of mono.
I have now filed a bug upstream with Mono/Xamarin,
https://bugzilla.xamarin.com/show_bug.cgi?id=53154
A bug can only be fixed if it is reported...

Timotheus

----------------------------------------------------------------
Diese Nachricht wurde versandt mit Webmail von www.tbits.net.
This message was sent using webmail of www.tbits.net.
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)