Crash on startup (segfault)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Crash on startup (segfault)

lineinthesand
Hello!

I'm trying to run banshee on openSUSE (official package) under KDE, but
it crashes immediately at startup (segfault):


[Info  21:34:36.953] Running Banshee 2.6.2: [openSUSE 13.2 (linux-gnu,
x86_64) @ 2014-10-15 18:21:59 UTC]
Stacktrace:

  at <unknown> <0xffffffff>
  at Banshee.Gui.GtkBaseClient.Initialize (bool) <0x00043>
  at Banshee.Gui.GtkBaseClient..ctor (bool,string) <0x0005f>
  at Banshee.Gui.GtkBaseClient..ctor () <0x0001b>
  at Nereid.Client..ctor () <0x0000f>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__
(object,intptr,intptr,intptr) <0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native)
System.Reflection.MonoCMethod.InternalInvoke
(System.Reflection.MonoCMethod,object,object[],System.Exception&)
<0xffffffff>
  at System.Reflection.MonoCMethod.InternalInvoke (object,object[])
<0x0003f>
  at System.Activator.CreateInstance (System.Type,bool) <0x00146>
  at System.Activator.CreateInstance (System.Type) <0x0000e>
  at Banshee.Gui.GtkBaseClient.Startup () <0x0001c>
  at Hyena.Gui.CleanRoomStartup.Startup
(Hyena.Gui.CleanRoomStartup/StartupInvocationHandler) <0x000ae>
  at Banshee.Gui.GtkBaseClient.Startup<T> () <0x0009f>
  at Banshee.Gui.GtkBaseClient.Startup<T> (string[]) <0x00103>
  at Nereid.Client.Main (string[]) <0x00017>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object
(object,intptr,intptr,intptr) <0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.AppDomain.ExecuteAssembly
(System.AppDomain,System.Reflection.Assembly,string[]) <0xffffffff>
  at System.AppDomain.ExecuteAssemblyInternal
(System.Reflection.Assembly,string[]) <0x00044>
  at System.AppDomain.ExecuteAssembly
(string,System.Security.Policy.Evidence,string[]) <0x00034>
  at (wrapper remoting-invoke-with-check)
System.AppDomain.ExecuteAssembly
(string,System.Security.Policy.Evidence,string[]) <0xffffffff>
  at System.AppDomain.ExecuteAssembly (string) <0x0001c>
  at (wrapper remoting-invoke-with-check)
System.AppDomain.ExecuteAssembly (string) <0xffffffff>
  at Booter.Booter.BootClient (string) <0x00092>
  at Booter.Booter.Main () <0x001e7>
  at (wrapper runtime-invoke) object.runtime_invoke_void
(object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

[1]    896 segmentation fault  /usr/bin/banshee

I just cannot find out what the problem is. Weird thing is: when I
compile it from source, it runs without a problem.

Can anyone help me debugging this?

Thanks,

Thomas
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)