Community Extensions for trusty / MINT 17.1 ?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Community Extensions for trusty / MINT 17.1 ?

ChristianH
Does anybody know if community extensions will be released for ubuntu trusty (14.04 LTS) or MINT 17.1 respectively?

Especially the mirage-extension I am using with ubuntu precise (12 LTS)?

Or if elder version run with trusty when tarballed into?

Thanks in advance

Christian
Reply | Threaded
Open this post in threaded view
|

Re: Community Extensions for trusty / MINT 17.1 ?

WarwickTaylor
ChristianH wrote
Does anybody know if community extensions will be released for ubuntu trusty (14.04 LTS) or MINT 17.1 respectively?

Especially the mirage-extension I am using with ubuntu precise (12 LTS)?

Or if elder version run with trusty when tarballed into?

Thanks in advance

Christian
Hi Christian,

Not sure if this helps...

On this page
http://banshee.fm/download/extensions/
down below the list is this link ('Source Tarballs")

http://download.banshee-project.org/banshee-community-extensions/

There are tarballs and zips in there but I do not know how to get from them - to a working Extension.

If you do - please reply and tell me how - as I would like to install the Lyrics extension included in there.
I'm on Mint 17.2 Cinnamon  & as expected there is no 'community-extensions' in their repos.

Warwick
WFTaylor@gmail.com
Reply | Threaded
Open this post in threaded view
|

Re: Community Extensions for trusty / MINT 17.1 ?

ChristianH



> > Does anybody know if community extensions will be released for ubuntu
> > trusty (14.04 LTS) or MINT 17.1 respectively?
> >
> > Especially the mirage-extension I am using with ubuntu precise (12 LTS)?
> >

> Not sure if this helps...
>
> On this page
> http://banshee.fm/download/extensions/
> <http://banshee.fm/download/extensions/>  
> down below the list is this link ('Source Tarballs")
>
> http://download.banshee-project.org/banshee-community-extensions/
> <http://download.banshee-project.org/banshee-community-extensions/>  
>
> There are tarballs and zips in there but I do not know how to get from them
> - to a working Extension.

I an sorry, I am not familiar with using these sources -  I do not know hw to compile things.

That's why I asked if anybody might have an idea on using binary extensions that were made for elder ubuntu releases.

In the meatime I found community extensions for newer releases than trusty, i.e. vivid and wiley (https://launchpad.net/banshee-community-extensions/+packages) But trying to install them in trusty ran (as expected) into chaos with dependencies.

My current solution is using an elder laptop with 12LTS for playing music files - not exactly elegant but works

Christian
_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)
Reply | Threaded
Open this post in threaded view
|

Re: Community Extensions for trusty / MINT 17.1 ?

ChristianH
In reply to this post by ChristianH
ChristianH wrote
Does anybody know if community extensions will be released for ubuntu trusty (14.04 LTS) or MINT 17.1 respectively?
[...]
Still no release fpr trusty available but Ubuntu has updated lots of libraries.

Today installing .deb packages made for vivid (which is the wrong ubuntu release) worked as a dirty workaround to get mirage running with my MINT 17.2 ( = ubuntu 14.04 LTS).

This workaround is not recommended because
- installing .deb packages in unbuntu is usually not a good idea
- installing .deb packages from wrong releases is even a worse idea
- both can destroy your system

The workaround:
- be sure to have your data backupped, your system might be damaged!
- do an apt-get dist-upgrade and an apt-get upgrade to have all the library updates installed
- install banshee-extensions-common 2.4.0-4ubuntu1 with GDebi
  for my system I found them here:
  https://launchpad.net/ubuntu/vivid/amd64/banshee-extensions-common/2.4.0-4ubuntu1
- do an apt-get check to check if the dependencies work
    -If apt-get check reports no errors: proceed
    -If apt-get check reports errors: uninstall the package with GDebi and
        - forget the workaraound or
        - try a package for another type of processor, found here:
          https://launchpad.net/ubuntu/vivid/+source/banshee-community-extensions
- Install the mirage .deb with GDebi
  I found mine here:
  https://launchpad.net/ubuntu/vivid/i386/banshee-extension-mirage/2.4.0-4ubuntu1
- do an apt-get check to check if the dependencies work
   - if not: Uninstall with GDebi
- Start Synaptic (it performs some more checks, if it doesn't report errors, anything shoud work and you should find mirage in banshee, now.

Christian
Reply | Threaded
Open this post in threaded view
|

Re: Community Extensions for trusty / MINT 17.1 ?

ChristianH
<quote author="ChristianH">
ChristianH wrote
Today installing .deb packages made for vivid (which is the wrong ubuntu release) worked as a dirty workaround to get mirage running with my MINT 17.2 ( = ubuntu 14.04 LTS).
My Linux MINT is the xfce version.
I haven't tried it with anythin else.
Christian