Building Banshee 2.9.1 on Linux Mint 17.2 (based on Ubuntu 14.04)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Building Banshee 2.9.1 on Linux Mint 17.2 (based on Ubuntu 14.04)

Obsidian Jackal
On LM 17.2, I was following the Ubuntu steps from http://banshee.fm/download/development/.

Running `sudo apt-get build-dep banshee` gave the error "E: Failed to satisfy Build-Depends dependency for banshee: Installed package libgpod-cil-dev is too new" because of this bug, so I tried using `sudo aptitude build-dep banshee` and here is what it needs to fulfill that request:
The following NEW packages will be installed:
  autopoint{a} cli-common-dev dh-autoreconf dh-translations
  gir1.2-gtk-2.0{a} gir1.2-javascriptcoregtk-1.0{a} gir1.2-webkit-1.0{a}
  gnome-doc-utils libatk1.0-dev{a} libcairo-script-interpreter2{a}
  libcairo2-dev{a} libdbus-glib-1-dev libdbus-glib2.0-cil-dev
  libdbus2.0-cil-dev libexpat1-dev{a} libfontconfig1-dev{a}
  libfreetype6-dev{a} libgdata-cil-dev libgdk-pixbuf2.0-dev{a}
  libgio-cil{a} libgio2.0-cil-dev libgkeyfile-cil-dev libglib2.0-cil-dev
  libgnome-desktop-2-17{a} libgnome-desktop-dev libgpod-cil{a}
  libgpod-cil-dev libgstreamer-plugins-base1.0-dev libgstreamer1.0-dev
  libgtk-sharp-beans2.0-cil-dev libgtk2.0-cil-dev libgtk2.0-dev
  libgudev1.0-cil-dev libharfbuzz-dev{a} libharfbuzz-gobject0{a}
  libice-dev{a} libjavascriptcoregtk-1.0-dev{a} libmono-addins-cil-dev
  libmono-upnp-cil{a} libmono-upnp-cil-dev libmono-zeroconf-cil-dev
  libmtp-dev libnotify-cil-dev libpango1.0-dev{a} libpixman-1-dev{a}
  libpng12-dev{a} libpthread-stubs0-dev{a} libsm-dev{a}
  libsoup-gnome2.4-dev libsoup2.4-dev libsqlite3-dev
  libstartup-notification0-dev{a} libtaglib-cil-dev libusb-1.0-0-dev{a}
  libwebkitgtk-dev libwnck-dev libx11-dev libxau-dev{a}
  libxcb-render0-dev{a} libxcb-shm0-dev{a} libxcb1-dev{a}
  libxcomposite-dev{a} libxcursor-dev{a} libxdamage-dev{a} libxdmcp-dev{a}
  libxext-dev{a} libxfixes-dev{a} libxft-dev{a} libxi-dev{a}
  libxinerama-dev{a} libxml-dom-perl{a} libxml-perl{a}
  libxml-regexp-perl{a} libxml2-utils{a} libxrandr-dev libxrender-dev{a}
  libxres-dev{a} libxxf86vm-dev x11proto-composite-dev{a}
  x11proto-core-dev{a} x11proto-damage-dev{a} x11proto-fixes-dev{a}
  x11proto-input-dev{a} x11proto-kb-dev{a} x11proto-randr-dev{a}
  x11proto-render-dev{a} x11proto-resource-dev{a} x11proto-xext-dev{a}
  x11proto-xf86vidmode-dev{a} x11proto-xinerama-dev{a}
  xorg-sgml-doctools{a} xsltproc{a} xtrans-dev{a}
The following packages will be REMOVED:
  libconfig9{u} libevent-core-2.0-5{u} libevent-pthreads-2.0-5{u}
  libglademm-2.4-1c2a{u} libgtkglextmm-x11-1.2-0{u} libnet-dbus-perl{u}
  libsoxr0{u} libxml-twig-perl{u}

Doing this would probably break a couple things in my OS.
Reply | Threaded
Open this post in threaded view
|

Re: Building Banshee 2.9.1 on Linux Mint 17.2 (based on Ubuntu 14.04)

bobdole
This post was updated on .
I also have an issue installing banshee 2.9.1 in linux mint 17.2.

I did not try your way ( I wasn't aware this was even possible, I know my around compiling and other terminal stuff but I didn't know about this).

I compile the tarball with all the required packages, and I get an error after doing ./configure, which is pretty strange, only saw this happen once and it was with a ragtag aol messenger clone for debian and debian based distros.

I'm going to try again and show what happens, maybe I can get help, it's been more than a year that I wanted to install Banshee past 2.9.1, one reason, although not the most important, is that BPM detection was better back in Ubuntu 11.10, the last Ubuntu I've used before it became, well, I won't mince my words, shitty, and discovered LM.

it's an error during make or make install, I forget which, I tried checkinstall and it didn't help either.

If you've found how to do it on Linux Mint 17 x64, I'd love to hear how.

Thanks.

Oh and by the way using aptitude, for me, did not result in being questioned if I wanted any software removed, only some installed.

So I installed those, no problem. What am I supposed to do now? Banshee is still 2.6.2 ?
Reply | Threaded
Open this post in threaded view
|

Re: Building Banshee 2.9.1 on Linux Mint 17.2 (based on Ubuntu 14.04)

ChristianH
> I also have an issue installing banshee 2.9.1 in linux mint 17.2.
>[...]
> If you've found how to do it on Linux Mint 17 x64, I'd love to hear how.

A 2.9.0+really2.6.2-ubuntu2.1 is in the trusty-updates repository.

If the 2.6. that comes with Linux Mint does not update to this version,
you can force installation with synaptic.

O.k. not 2.9.1. but maybe it solves your problem

_______________________________________________
banshee-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/banshee-list  (unsubscribe here)